I have an RF attached keyboard (Speedlink SL-6495) with a build-in trackball. A very nice device with a limited, but sufficient range. It works without drivers as long as you do not need the hotkeys.



I had two problems, however:

First, if the ID-key on the keyboard is pressed, it will try to make a new pairring with the receiver - and you will have to press the corresponding pairring button on the receiver (and then probably the ID key again before it times out). This means that you will have to place the receiver on an USB extension cable (not included) in order to get to it whenever you accidently press the ID-key. On the other hand, this enables you to place it on a point with good reception..

Secondly, I had a problem under kernel 2.6.21 and Xorg 1.3.0, Debian Lenny. When in X, the keyboard suddently became stuck, meaning that it would repeat the last key and stop accepting new keys. The activity LED on the receiver did not blink, and even detaching the USB keyboard receiver did not stop the repeating. At the same time, the mouse on the keyboard worked perfectly.

I tried, based on some googling, to increase the repeat timeout and latency, but without any effect. In the end, I found out it was because the X was started in a console using getty. As I had it setup to do an autologin (not a secure thing, but this is a mediacenter..), I changed the lines in inittab to uncomment a virtual console and add X there: #6:23:respawn:/sbin/getty 38400 tty6
6:12345:respawn:/usr/local/bin/autologin tty6 login -f mythtv
Note the commenting of the first line. By the way, my /usr/local/bin/autologin script (based on this) is: #!/bin/bash
exec 0\/dev/$1 2>&1
cat /etc/issue
shift
exec $*
Even then, the phenomenon can reappear when using showkey or xed.
This was not an issue under kernel 2.6.18-3 and Xorg 7.1.1, Debian Etch..

The hotkeys

Being a multimedia keyboard, it has some hotkeys too. To get them to work, do:
  • Run showkey or xed and determine the (multibyte) scan code sequences of the keyboard special keys.
  • Check xmodmap -pke >xmodmap.conf to see if they all are defined, and to what symbol. If not, fill in the table with values from /usr/lib/X11/XKeysymDB or /usr/share/X11/XKeysymDB.
  • Load it with xmodmap xmodmap.conf
  • Use the Keyboard Shortcut utility under Settings in Gnome to assign actions to hotkeys.

    See also here. Even then, only programs supporting multimedia keys will react to them.